Wednesday 11th November 2015

High Connection count on MySQL database leads to connection errors

Since 5 minutes ago, we are seeing very high connection counts and some features are not available in the user interface. We are investigating the issue and try to fix asap.

Update: 14:24 The database saw a very high number of connections and dropped some of them. We have stabilized connections now by reducing the number of database intensive workers that currently operate on the MySQL database and the site is back up. As a next step we will improve load to our database to avoid this incident in the future.

Update: 16:30 We sized up the database to handle more connections to avoid this problem. We ran into this because we increased the number of background workers significantly in the last days.