PHP Extension 5.4.36 broken on Ubuntu 18.04 and older Debian systems
Incident Report for Tideways
Resolved
We have verified that the newly published package fixes the issue with several affected customers.

Should you still experience any issues, please get in touch with us via support@tideways.com.

We sincerely apologize for any trouble this caused you.
Posted Feb 21, 2022 - 15:16 CET
Update
We have published 5.4.38 that includes a fix for the GLIBC / clock_get_time relocation error and verified that it works for Ubuntu 18.04 machines were we could reproduce the error with 5.4.36.

Let us know if this updated package works or does not work for you by writing to support@tideways.com
Posted Feb 21, 2022 - 14:47 CET
Monitoring
We verified a bugfix and are now building a new version 5.4.38 to be published within the hour.
Posted Feb 21, 2022 - 14:12 CET
Identified
We have identified the problem in a move of the C function clock_gettime in more modern versions from librt to glibc. Our build setup had code to account for this, but it looks like a new flag caused this to be ignored instead of forced for compatibility. We are building a new version of the PHP extension at the moment and testing on a freshly setup Ubuntu 18.04 next.
Posted Feb 21, 2022 - 14:01 CET
Investigating
A new PHP extension release 5.4.36 that was published earlier this morning is causing problems with Ubuntu 18.04 and older Debian versions.

Please downgrade to 5.4.34 if you are seeing the error: “relocation error: /path/to/tideways.so: symbol clock_gettime version GLIBC_2.2.5 not defined in file libc.so.6 with link time reference”.

We are urgently working on a fix.
Posted Feb 21, 2022 - 12:30 CET
This incident affected: Ecosystem.